Статьи и заметки об информационных технологиях
Блудная статья
О компании// Статьи// Рубрикатор// Каталог оборудования//
Поиск// Карта сайта// RSS// Ссылки//

Настройка NAT через один FastEthernet-интерфейс на маршрутизаторе Cisco [10.03.2007]

Как настроить NAT на маршрутизаторе Cisco, имея только один FastEthernet-интерфейс.

В ситуации, когда есть маршрутизатор с одним Serial-интерфейсом и одним FastEthernet-интерфейсом, все же можно организовать NAT для внутренней сети и одновременно иметь реальный адрес для предоставления доступа снаружи, например, к web-серверу. В рассматриваемом примере Serial-интерфейс подключен к провайдеру, FastEthernet-интерфейс – к коммутатору с поддержкой VLAN (Catalyst 2950). Настроены два VLAN – VLAN 1 (публичный) и VLAN 110 – (частный с NAT).

ip dhcp pool Client
   network 192.168.99.0 255.255.255.0
   domain-name domain.com
   dns-server XXX.XXX.XXX.100
   default-router 192.168.99.1
   netbios-node-type b-node

interface FastEthernet0/0
 no ip address
 ip route-cache flow
 no ip mroute-cache
 duplex auto
 speed auto
 no cdp enable

interface FastEthernet0/0.1
 description Public interface for hosting/collocation
 encapsulation isl 1
 ip address XXX.XXX.XXX.1 255.255.255.128
 ip access-group 111 in
 ip access-group 112 out
 no ip redirects
 ip accounting output-packets
 ip nat outside
 no cdp enable

interface FastEthernet0/0.105
 description Client interface with private addresses
 bandwidth 10000
 encapsulation isl 110
 ip address 192.168.99.1 255.255.255.0
 no ip redirects
 ip accounting output-packets
 ip nat inside
 no cdp enable

interface Serial1/0
 description Interface for connection to ISP
 bandwidth 2048
 ip address YYY.YYY.YYY.YYY 255.255.255.252
 no ip proxy-arp
 ip accounting output-packets
 ip nat outside
 no ip mroute-cache
 no fair-queue
 no cdp enable

ip nat pool Clients XXX.XXX.XXX.99 XXX.XXX.XXX.99 netmask 255.255.255.0
ip nat inside source list 99 pool Clients overload
ip classless
access-list 99 permit 192.168.99.0 0.0.0.255

Здесь сеть XXX.XXX.XXX.0 – реальные адреса, YYY.YYY.YYY.YYY - реальный адрес для Serial-интерфейса, предоставленные провайдером. Один из этих адресов (в примере – XXX.XXX.XXX.99) подставляется для исходящих пакетов, а для исходящих используется адрес из внутренней сети (192.168.99.XXX)



del.icio.us News2 Digg Furl ma.gnolia Technorati Cosmos Blinklist Yahoo! My Web BlinkBits Blogmarks Co.mments.com Connotea De.lirio.us Fark Feedmelinks LinkaGoGo NewsVine Netvouz RawSugar ReddIt Scuttle Shadows Simply Smarking Spurl TailRank Wists Segnalo Добавить на Mr. Wong Добавить на Webnews Добавить на  Icio Добавить на Oneview Добавить на Folkd Добавить на Yigg Добавить на Linkarena Добавить на StumbleUpon Добавить на Slashdot Добавить на Netscape Добавить на Google Добавить на Diigo Забобрить эту страницу! Добавить в закладки МоёМесто.ru
Постоянный адрес страницы: http://www.hypercomp.ru/articles/configuring-nat-using-single-fastethernet-interface/

Комментарии [44]
Ваш комментарий
Имя *

Фамилия *

E-mail  

WWW  

Комментарий * :-) ;-) :-( :-D 8-) :-o :roll: :unknown: :lol: :bad: :good: :no: :oops:

  Введите код с картинки:


Обычно проблема выражается в следующем: при выборе домена для входа на экране входа в систему список доменов "зависает" на минуту, иногда больше; при ...
Тематика статьи
Разное
Яндекс цитирования
Rambler's Top100 Рейтинг@Mail.ru
О проекте // Статьи // Рубрикатор // Поиск // Карта сайта // RSS // СсылкиTo the skies!

© hypercomp.ru, 1982-2018 Куап.ру - база данных российских банков
 hypercomp.ru