Статьи и заметки об информационных технологиях
Блудная статья
О компании// Статьи// Рубрикатор// Каталог оборудования//
Поиск// Карта сайта// RSS// Ссылки//

Как настроить VLAN на коммутаторе Cisco Catalyst [17.02.2007]


Технология VLAN позволяет сегментировать локальную сеть логически, создавая индивидуальные подсети, независимо от физического расположения клиентов. Также создание VLAN уменьшает размеры широковещательных доменов (broadcast domains), что повышает производительность сети. Связь между VLAN возможно только с помощью устройств, работающих на 3 уровне сетевой модели OSI – маршрутизаторов и гибридных коммутаторов.

В первую очередь нужно решить, будет ли использоваться VTP (Virtual Trunking Protocol) VTP позволяет конфигурировать VLAN’ы только на одном коммутаторе, работающем в VTP-режиме server, а остальные будут получать информацию с него, работая в VTP-режиме client. По умолчанию на коммутаторах Catalyst 2900XL, 3500XL, 2950, 2970 и 2940 установлен VTP-режим server. Команда show vtp status позволяет посмотреть текущие настройки VTP. Если настраивать будем на каждом коммутаторе в отдельности, то на обоих устанавливаем режим server.

#vlan database
(vlan)#vtp server

По умолчанию существует единственный VLAN – VLAN 1 (default). Переименовать или удалить его нельзя. С помощью команды show vlan можно увидеть действующие VLAN’ы и порты коммутатора, относящиеся к ним. Создавать VLAN можно только если коммутатор работает в VTP-режимах server или transparent. Для создания нового VLAN нужно набрать:

#vlan database
#(vlan)#vlan 2 name cisco_vlan_2
#(vlan)#exit

Теперь добавим порты в новый VLAN. Делается это следующим образом.

#configure terminal
(config)#interface vlan 2
(config-subif)#management
(config-subif)#^Z                        #(Ctrl+Z)
(config)#interface fastethernet 0/2
(config-if)#switchport access vlan 2
(config-if)#exit
(config)#interface fastethernet 0/3
(config-if)#switchport access vlan 2
(config-if)#end
#write memory

Можно давать команды сразу нескольким портам, используя команды вида

(config)#interface range fastethernet 0/1 - 24

Удалить VLAN можно командой no vlan 2, а удалить отдельный порт из VLAN – no switchport access vlan 2. После удаления из VLAN порты переходят в VLAN по умолчанию – первый.  Некоторые коммутаторы позволяют назначить порту сразу несколько VLAN, хотя работать он одновременно все равно может только в одном:

(config-if)#switchport multi vlan 1,2,3

После создания VLAN он появляется в списке интерфейсов, и можно назначить ему IP-адрес для управления коммутатором. Уберем адрес с VLAN 1 и настроим его на VLAN 2:

(config)#interface vlan 1
(config-if)#no ip address
(config-if)#shutdown
(config-if)#exit
(config)#interface vlan 2
(config-subif)#ip address 192.168.1.1 255.255.255.0
(config-subif)#no shutdown

Для связи двух коммутаторов с настроенными одинаковыми VLAN порты, через которые они связаны, должны быть настроены не на режим switchport mode access, а на switchport mode trunk.

(config)#interface FastEthernet 0/1
(config-if)#switchport mode trunk

Trunk позволяет через один соединяющий коммутаторы кабель передавать данные из всех работающих VLAN, в то же время разделяя их друг от друга.

Подробнее о настройке VLAN можно почитать здесь (на английском языке): http://www.cisco.com/en/US/tech/tk389/tk689/technologies_configuration_example09186a008009478e.shtml



del.icio.us News2 Digg Furl ma.gnolia Technorati Cosmos Blinklist Yahoo! My Web BlinkBits Blogmarks Co.mments.com Connotea De.lirio.us Fark Feedmelinks LinkaGoGo NewsVine Netvouz RawSugar ReddIt Scuttle Shadows Simply Smarking Spurl TailRank Wists Segnalo Добавить на Mr. Wong Добавить на Webnews Добавить на  Icio Добавить на Oneview Добавить на Folkd Добавить на Yigg Добавить на Linkarena Добавить на StumbleUpon Добавить на Slashdot Добавить на Netscape Добавить на Google Добавить на Diigo Забобрить эту страницу! Добавить в закладки МоёМесто.ru
Постоянный адрес страницы: http://www.hypercomp.ru/articles/configuring-vlans-on-cisco-catalyst-switches/

Комментарии [28]
Ваш комментарий
Имя *

Фамилия *

E-mail  

WWW  

Комментарий * :-) ;-) :-( :-D 8-) :-o :roll: :unknown: :lol: :bad: :good: :no: :oops:

  Введите код с картинки:


Одним из нововведений операционной системы маршрутизаторов Cisco IOS версии 12.0 и старше, отличающим ее от предшественников, являлись (и являются в с ...
Тематика статьи
Разное
Яндекс цитирования
Rambler's Top100 Рейтинг@Mail.ru
О проекте // Статьи // Рубрикатор // Поиск // Карта сайта // RSS // СсылкиTo the skies!

© hypercomp.ru, 1982-2018 Куап.ру - база данных российских банков
 hypercomp.ru