Статьи и заметки об информационных технологиях
Блудная статья
О компании// Статьи// Рубрикатор// Каталог оборудования//
Поиск// Карта сайта// RSS// Ссылки//

Как связать аналоговые телефоны через VoIP [25.02.2007]

Простой пример настройки двух голосовых маршрутизаторов Cisco для связи двух аналоговых телефонов (порты FXS) через VoIP.
Рассмотрим пример того, как можно настроить обмен голосовыми данными для аналоговых телефонов (подключаемых через FXS-порты) с помощью VoIP-транспорта между двумя голосовыми шлюзами (или маршрутизаторами с поддержкой голосовых функций). Приведенный ниже пример показывает настройки двух маршрутизаторов (в данном случае, Cisco 2620 с модулями 2FXS) для связи между собой. Аналоговым телефонам даются номера 1001 и 1002. Для каждого конкретного случая следует проверить нумерацию портов командой show ip interfaces brief. Соединение маршрутизаторов Cisco осуществляется по последовательным интерфейсам Serial0 - для голосовых шлюзов с FastEthernet-интерфейсами, естественно, не получится применить тип инкапсуляции ppp. Тогда настройки маршрутизаторов Cisco изменятся следующим образом - IP-адреса дает интерфейсам FastEthernet0/0, через которые и связываем два маршрутизатора.

Голосовой маршрутизатор Cisco 2620 #1:
--------------------------------------

hostname c2620-1

memory-size iomem 15
ip subnet-zero

voice-port 2/0

voice-port 2/1

dial-peer voice 1 pots
 destination-pattern 1001
 port 2/0

dial-peer voice 2 voip
 destination-pattern 1002
 ip precedence 5
 session target ipv4:192.168.0.2

process-max-time 200

interface Serial0
 ip address 192.168.0.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 ip rtp header-compression iphc-format
 ip rtp compression-connections 3
 ip tcp header-compression iphc-format
 no ip mroute-cache
 no fair-queue
 clockrate 28800

interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 shutdown

interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown

ip classless
no ip http server

line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4

no scheduler allocate
end


Голосовой маршрутизатор Cisco 2620 #2:
--------------------------------------
hostname c2620-2

memory-size iomem 15
ip subnet-zero

voice-port 2/0

voice-port 2/1

dial-peer voice 1 pots
 destination-pattern 1002
 port 2/0

dial-peer voice 2 voip
 destination-pattern 1001
 ip precedence 5
 session target ipv4:192.168.0.1

process-max-time 200

interface Serial0
 ip address 192.168.0.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 ip rtp header-compression iphc-format
 ip rtp compression-connections 3
 ip tcp header-compression iphc-format
 no ip mroute-cache
 no fair-queue
 clockrate 28800

interface FastEthernet0/0
 no ip address
 no ip directed-broadcast
 shutdown

interface FastEthernet0/1
 no ip address
 no ip directed-broadcast
 shutdown

ip classless
no ip http server

line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4

no scheduler allocate
end



del.icio.us News2 Digg Furl ma.gnolia Technorati Cosmos Blinklist Yahoo! My Web BlinkBits Blogmarks Co.mments.com Connotea De.lirio.us Fark Feedmelinks LinkaGoGo NewsVine Netvouz RawSugar ReddIt Scuttle Shadows Simply Smarking Spurl TailRank Wists Segnalo Добавить на Mr. Wong Добавить на Webnews Добавить на  Icio Добавить на Oneview Добавить на Folkd Добавить на Yigg Добавить на Linkarena Добавить на StumbleUpon Добавить на Slashdot Добавить на Netscape Добавить на Google Добавить на Diigo Забобрить эту страницу! Добавить в закладки МоёМесто.ru
Постоянный адрес страницы: http://www.hypercomp.ru/articles/how-to-connect-analog-phones-over-voip/

Комментарии [6]
Ваш комментарий
Имя *

Фамилия *

E-mail  

WWW  

Комментарий * :-) ;-) :-( :-D 8-) :-o :roll: :unknown: :lol: :bad: :good: :no: :oops:

  Введите код с картинки:


Не так давно нежно любимая в нашей стране корпорация Microsoft выпустила последнее большое обновление для Windows XP - Service Pack 3. Несмотря на ...
Тематика статьи
Разное
Яндекс цитирования
Rambler's Top100 Рейтинг@Mail.ru
О проекте // Статьи // Рубрикатор // Поиск // Карта сайта // RSS // СсылкиTo the skies!

© hypercomp.ru, 1982-2018 Куап.ру - база данных российских банков
 hypercomp.ru